Repository navigation
fix: require a Node.js release with the October 2026 security fixes - #55
Closed
FranDisalvo90 wants to merge 1 commit into
Closed
FranDisalvo90 wants to merge 1 commit into
FranDisalvo90 wants to merge 1 commit into
Conversation
Node.js 22.23.4 and 24.22.1 patch ten vulnerabilities, including a remote code execution in the Brotli decoder and two TLS hostname verification bypasses. The NestJS example pinned 22.14.0 and the READMEs still asked for Node.js 18, which is end-of-life. - engines and devEngines: >=24.0.0 -> >=24.22.1 - CI: Node 24.22.1 - examples/node-nestjs/.nvmrc: v22.14.0 -> v22.23.4 - READMEs: Node.js 18+ -> a patched release Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com>
Author
|
Closing: this project is out of scope for now. Its CI is blocked by outdated dependencies unrelated to the Node.js version change. |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Why
The Node.js security releases of 2026-10-21 fix ten vulnerabilities, four of them high (Brotli decoder RCE, two TLS hostname verification bypasses,
dns.resolvetruncation). People copy these examples as the base of their integration: the NestJS example pinned an unpatched 22.14.0, and several READMEs still asked for Node.js 18, which is end-of-life.What
enginesanddevEngines.runtime:>=24.0.0→>=24.22.1in the five pnpm projects (both have to move: pnpm 11 checksenginesagainst the lower bound ofdevEngines.runtime).examples/node-nestjs/.nvmrc:v22.14.0→v22.23.4.Node.js 18+→ a patched release.Verified
On Node 24.22.1,
pnpm install --frozen-lockfilepasses in all five projects.🤖 Generated with Claude Code